What’s Vulnerable › Vulnerabilities
CVE-2026-9066: WP Compress < 7.10.04 - Reflected XSS via test_zone
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-07-23
- Weakness: CWE-79
Description
The WP Compress WordPress plugin before 7.10.04 does not validate the value of a query parameter that controls the asset CDN host before using it to build the URLs of JavaScript files emitted on the page, leading to Reflected XSS. When a visitor follows a crafted link, the WP Compress WordPress plugin before 7.10.04's loader injects script elements pointing to an attacker-controlled origin, which lets the attacker execute arbitrary JavaScript in the visitor's session on the target site.
Affected products
- WP Compress: before 7.10.04 — fixed in 7.10.04
How to fix
Upgrade to a fixed version: WP Compress 7.10.04. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9066 or the next vulnerability affects your stack