What’s Vulnerable › Vulnerabilities
CVE-2026-90668
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-13 · updated 2026-09-22
- Weakness: CWE-770
Description
The webserver in UnrealIRCd 6.0.5 through 6.2.6 before 6.2.7 does not limit the number of HTTP request headers, which allows remote attackers to cause a denial of service (memory consumption and unresponsive server) via an HTTP request with an unlimited number of headers, if a websocket or JSON-RPC listener is enabled (disabled by default).
Affected products
- UnrealIRCd: from 6.0.5 before 6.2.7 — fixed in 6.2.7
How to fix
Upgrade to a fixed version: UnrealIRCd 6.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-90668 or the next vulnerability affects your stack