What’s Vulnerable › Vulnerabilities
CVE-2026-90776: Nodemailer 9.1.0 through 10.0.4 Denial of Service via Quadratic Address Parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-13 · updated 2026-09-24
- Weakness: CWE-407
Description
Nodemailer versions 9.1.0 through 10.0.4 contain a quadratic time complexity vulnerability in the addressparser component when parsing email addresses with RFC 5322 comments. Attackers can craft malicious email headers with comment-separated atoms to consume excessive CPU and block the Node.js event loop for several seconds, causing denial of service.
Affected products
- nodemailer: from 9.1.0 before 10.0.5 — fixed in 10.0.5
How to fix
Upgrade to a fixed version: nodemailer 10.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/nodemailer/nodemailer
- https://github.com/nodemailer/nodemailer/blob/v10.0.4/src/addressparser/index.ts#L251
- https://github.com/nodemailer/nodemailer/commit/c07f17518d25aca8ab2ad66968dcbca538c24b89
- https://github.com/nodemailer/nodemailer/releases/tag/v10.0.5
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-prgh-xp8r-p3m5
- https://www.vulncheck.com/advisories/nodemailer-9.1.0-through-10.0.4-denial-of-service-via-quadratic-address-parsing
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-prgh-xp8r-p3m5
Get alerted when CVE-2026-90776 or the next vulnerability affects your stack