What’s Vulnerable › Vulnerabilities
CVE-2026-90800: Apache CouchDB: Auth bypass in prefixed _users and _replicator databases
- Severity: high (CVSS 8.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-20
- Weakness: CWE-862
Description
Missing authorisation checks in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows any request to read the full contents of a prefixed _user or _replicator database via an unauthorised API endpoint. The use of prefixed system databases is very rare. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
Affected products
- Apache Software Foundation Apache CouchDB: before 3.5.3 — fixed in 3.5.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CouchDB 3.5.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/pj83174r8f8f64odf47fwhozbfjtot0f
- https://lists.apache.org/thread/vng8vqjwgy1qlrv14wzrgs7pv4gj7gwr
- http://www.openwall.com/lists/oss-security/2026/10/20/15
Get alerted when CVE-2026-90800 or the next vulnerability affects your stack