What’s Vulnerable › Vulnerabilities
CVE-2026-9081: Langflow OSS is affected by server-side request forgery in provider validation and API request functionality
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-24
- Weakness: CWE-918
Description
IBM Langflow OSS 1.0.0 through 1.10.3, and 1.0.0 through 1.10.3 contains a Server-Side Request Forgery (SSRF) vulnerability in the validate_model_provider_key() function for the Ollama provider. The function accepts a user-supplied OLLAMA_BASE_URL parameter and passes it directly to requests.get() without validation, scheme/host allowlisting, or filtering of private IP ranges (loopback, RFC1918, link-local addresses).
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9081 or the next vulnerability affects your stack