What’s Vulnerable › Vulnerabilities

CVE-2026-9082: Drupal Core SQL Injection Vulnerability

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Drupal Drupal core allows SQL Injection. This issue affects Drupal core: from 8.9.0 before 10.4.10, from 10.5.0 before 10.5.10, from 10.6.0 before 10.6.9, from 11.0.0 before 11.1.10, from 11.2.0 before 11.2.12, from 11.3.0 before 11.3.10.

Affected products

How to fix

Upgrade to a fixed version: Drupal 10.4.10, 10.5.10, 10.6.9, 11.1.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-9082 or the next vulnerability affects your stack