What’s Vulnerable › Vulnerabilities
CVE-2026-90852: luben zstd-jni Dictionary Sharing ZstdCompressCtx.java ZstdCompressCtx.loadDict use after free
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-15
- Weakness: CWE-119
Description
A vulnerability has been found in luben zstd-jni up to 1.5.7-13. This vulnerability affects the function ZstdCompressCtx.loadDict of the file ZstdCompressCtx.java of the component Dictionary Sharing. Such manipulation leads to use after free. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.7-14 is able to resolve this issue. The name of the patch is a560131d7834598afd9cea6b7c107bc88e915936. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Affected products
- luben zstd-jni: 1.5.7-13
References
- https://github.com/luben/zstd-jni/
- https://github.com/luben/zstd-jni/commit/a560131d7834598afd9cea6b7c107bc88e915936
- https://github.com/luben/zstd-jni/issues/404
- https://github.com/luben/zstd-jni/releases/tag/v1.5.7-14
- https://vuldb.com/cve/CVE-2026-90852
- https://vuldb.com/submit/927022
- https://vuldb.com/vuln/403407
- https://vuldb.com/vuln/403407/cti
Get alerted when CVE-2026-90852 or the next vulnerability affects your stack