What’s Vulnerable › Vulnerabilities
CVE-2026-9089
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-21 · updated 2026-07-23
- Weakness: CWE-494
Description
The ConnectWise Automate™ Agent does not fully verify the authenticity of components obtained during plugin loading and self-update operations. This issue is addressed in Automate 2026.5.
Affected products
- ConnectWise Automate: before 2026.5 — fixed in 2026.5
How to fix
Upgrade to a fixed version: ConnectWise Automate 2026.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9089 or the next vulnerability affects your stack