What’s Vulnerable › Vulnerabilities
CVE-2026-90910: Apache Answer: Reaction API authorization bypass for restricted content
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-19
- Weakness: CWE-306
Description
Missing authentication for critical function vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.2. The reaction API did not enforce content visibility controls, allowing unauthorized users to read reaction metadata from restricted content or add and remove their own reactions. Users are recommended to upgrade to version 2.0.3, which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: through 2.0.2
References
- https://lists.apache.org/thread/bhw80mvmnt9206wyqz80rcbwx1znv1p3
- http://www.openwall.com/lists/oss-security/2026/10/16/34
Get alerted when CVE-2026-90910 or the next vulnerability affects your stack