What’s Vulnerable › Vulnerabilities
CVE-2026-90935: Froxlor before 2.3.7 Authorization Bypass via Mysqls.add API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-10-08
- Weakness: CWE-285
Description
Froxlor before 2.3.7 fails to validate the mysql_server parameter against a customer's allowed_mysqlserver allowlist in the Mysqls.add API command. Attackers can supply a disallowed server index to create MySQL databases and users on forbidden servers, bypassing per-customer access controls.
Affected products
- froxlor: before 2.3.7 — fixed in 2.3.7
How to fix
Upgrade to a fixed version: froxlor 2.3.7. Check the vendor advisory for mitigations.
References
- https://github.com/froxlor/froxlor/security/advisories/GHSA-q4rm-m6xh-5pv7
- https://www.vulncheck.com/advisories/froxlor-before-2.3.7-authorization-bypass-via-mysqls-add-api
- https://github.com/froxlor/froxlor/security/advisories/GHSA-q4rm-m6xh-5pv7
Get alerted when CVE-2026-90935 or the next vulnerability affects your stack