What’s Vulnerable › Vulnerabilities
CVE-2026-90970: Improper Neutralization of Special Elements Used in a Template Engine in GitLab AI Gateway
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-1336
Description
GitLab has remediated a vulnerability in the GitLab AI Gateway component affecting all versions of the AI Gateway from 18.1.6 before 19.2.4, 19.3 before 19.3.2, and 19.4 before 19.4.1 that, under certain conditions, could have allowed an authenticated user with Duo Agent Platform access to escape the prompt template sandbox via a specially crafted flow configuration, resulting in arbitrary command execution on the AI Gateway.
Affected products
- GitLab: from 18.1.6 before 19.2.4; from 19.3 before 19.3.2; from 19.4 before 19.4.1 — fixed in 19.2.4, 19.3.2, 19.4.1
How to fix
Upgrade to a fixed version: GitLab 19.2.4, 19.3.2, 19.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-90970 or the next vulnerability affects your stack