What’s Vulnerable › Vulnerabilities
CVE-2026-90987: Easy PayPal & Stripe Buy Now Button 1.8 - 2.0.5 - Unauthenticated Payment Amount Manipulation via Client-Supplied Price
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-472
Description
The Easy PayPal & Stripe Buy Now Button WordPress plugin before 2.0.6 does not derive the payment amount on the server, taking it from a client-supplied field, so an unauthenticated attacker sets an arbitrary lower price for a purchase.
Affected products
- Easy PayPal & Stripe Buy Now Button: from 1.8 before 2.0.6 — fixed in 2.0.6
How to fix
Upgrade to a fixed version: Easy PayPal & Stripe Buy Now Button 2.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-90987 or the next vulnerability affects your stack