What’s Vulnerable › Vulnerabilities
CVE-2026-91002: stamparm maltrail Blacklist Endpoint httpd.py _blacklist missing authentication
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-15
- Weakness: CWE-287
Description
A weakness has been identified in stamparm maltrail up to 3.0.1. This vulnerability affects the function _blacklist of the file core/httpd.py of the component Blacklist Endpoint. Executing a manipulation can lead to missing authentication. The attack can be launched remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.1 is able to resolve this issue. This patch is called d95868dff3da4d3bd4f942837a26cb7c73a797ae. It is suggested to upgrade the affected component. The vendor fixed the issue the same day it was reported, in version 3.1, by gating the endpoint on an authenticated session or the new Blacklist_ALLOWLIST option.
Affected products
- stamparm maltrail: 3.0.0, 3.0.1
References
- https://gist.github.com/simyat/fd48e9c257ab95405c109aec575977f1
- https://github.com/stamparm/maltrail/
- https://github.com/stamparm/maltrail/commit/d95868dff3da4d3bd4f942837a26cb7c73a797ae
- https://github.com/stamparm/maltrail/releases/tag/3.1
- https://vuldb.com/cve/CVE-2026-91002
- https://vuldb.com/submit/931699
- https://vuldb.com/vuln/403583
- https://vuldb.com/vuln/403583/cti
Get alerted when CVE-2026-91002 or the next vulnerability affects your stack