What’s Vulnerable › Vulnerabilities
CVE-2026-91011: EWWW Image Optimizer < 8.7.7 - Author+ Stored XSS via Image Class Attribute Backreference Expansion
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-79
Description
The EWWW Image Optimizer WordPress plugin before 8.7.7 does not properly escape image attribute values when it rewrites page output, allowing authenticated users with author-level access and above to inject arbitrary JavaScript that is stored in published content and executes in the browser of any user who later views the affected page.
Affected products
- EWWW Image Optimizer: before 8.7.7 — fixed in 8.7.7
How to fix
Upgrade to a fixed version: EWWW Image Optimizer 8.7.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-91011 or the next vulnerability affects your stack