What’s Vulnerable › Vulnerabilities
CVE-2026-91017: Robokassa payment gateway for Woocommerce < 1.8.9 - Unauthenticated Payment Bypass via Forged JWT Callback
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-345
Description
The Robokassa payment gateway for Woocommerce WordPress plugin before 1.8.9 does not verify the authenticity of incoming payment notifications when its non-default deferred-payment feature is enabled, allowing unauthenticated attackers to forge a notification and mark arbitrary WooCommerce orders as paid or on-hold without payment or a valid signature.
Affected products
- Robokassa payment gateway for Woocommerce: before 1.8.9 — fixed in 1.8.9
How to fix
Upgrade to a fixed version: Robokassa payment gateway for Woocommerce 1.8.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-91017 or the next vulnerability affects your stack