What’s Vulnerable › Vulnerabilities

CVE-2026-91051: EWWW Image Optimizer 8.6.0 - 8.7.7 - Author+ PHP Object Injection via 'eio_page_settings' Post Meta

Description

The EWWW Image Optimizer WordPress plugin before 8.8.0 does not prevent authenticated users with author-level permissions from storing a serialized value in a post meta field that is deserialized when the post is rendered, allowing them to perform PHP Object Injection, which can lead to remote code execution when a suitable gadget chain is present via another installed EWWW Image Optimizer WordPress plugin before 8.8.0 or .

Affected products

How to fix

Upgrade to a fixed version: EWWW Image Optimizer 8.8.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-91051 or the next vulnerability affects your stack