What’s Vulnerable › Vulnerabilities

CVE-2026-9106: UI misrepresentation vulnerability in GitHub Enterprise Server allowed unauthorized organization runner management via undisclosed OAuth scope on consent screen

Description

A UI misrepresentation vulnerability was identified in GitHub Enterprise Server that allowed an OAuth application to gain unintended access to an organization's runner management. An attacker could exploit this by creating an OAuth application requesting the manage_runners:org scope and directing a victim user to authorize it, as the scope was not displayed on the authorization consent screen. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.21.2, 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.16.20, 3.17.17, 3.18.11, 3.19.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-9106 or the next vulnerability affects your stack