What’s Vulnerable › Vulnerabilities
CVE-2026-91076: Robokassa payment for WooCommerce < 1.9.0 - Unauthenticated Arbitrary Order Status Change to Failed
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-862
Description
The Robokassa payment gateway for Woocommerce WordPress plugin before 1.9.0 does not verify the authenticity of an incoming payment-notification request before acting on the order named in it, allowing unauthenticated attackers to force any WooCommerce order into a failed state. Order identifiers are sequential, so every order in the shop can be taken out of the fulfilment queue one request at a time.
Affected products
- Robokassa payment gateway for Woocommerce: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Robokassa payment gateway for Woocommerce 1.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-91076 or the next vulnerability affects your stack