What’s Vulnerable › Vulnerabilities
CVE-2026-91078: TillKit < 1.0.5 - Unauthenticated POS Takeover via Hard-Coded Default Manager PIN
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-03 · updated 2026-10-06
- Weakness: CWE-287
Description
The TillKit WordPress plugin before 1.0.5 does not require the hard-coded, publicly known PIN of the privileged POS account it creates on activation to be changed before use, and it authenticates its public POS login endpoint on that PIN alone with no identity or capability check, allowing unauthenticated attackers to obtain a privileged POS session and thereby read customer and site-user personal data and modify store data.
Affected products
- TillKit: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: TillKit 1.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-91078 or the next vulnerability affects your stack