What’s Vulnerable › Vulnerabilities
CVE-2026-91134: Discourse: Block post iframes whose encoded userinfo bypasses the allowed_iframes allowlist
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-29
- Weakness: CWE-20
Description
Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the Discourse post sanitizer allowed a stored cross-origin iframe to bypass the allowed_iframes prefix policy when the iframe src contained encoded userinfo. The sanitizer validated a decoded form differently from the stored iframe src, allowing the browser to interpret an attacker-controlled host while the allowlist check accepted the encoded URL as an allowed prefix. An authenticated user with posting privileges could persist the iframe in a post and cause attacker-controlled cross-origin content to be rendered. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.
Affected products
- discourse: before 2026.8.0; from 2026.7.0-latest, < 2026.7.2; from 2026.6.0-latest, < 2026.6.3; from 2026.1.0-latest, < 2026.1.8
References
- https://github.com/discourse/discourse/commit/0a8015e6c7a5079981843721494d30c9a91f5415
- https://github.com/discourse/discourse/commit/1304b0c04f87534053b0d574ae5a9b9ba13dd590
- https://github.com/discourse/discourse/commit/bac7dd1201911851462483271b4567246fa1309d
- https://github.com/discourse/discourse/commit/fed3a58c48412ce7207b72a4629ddbc44482cd64
- https://github.com/discourse/discourse/pull/42882
- https://github.com/discourse/discourse/security/advisories/GHSA-54vw-chv3-wjpv
Get alerted when CVE-2026-91134 or the next vulnerability affects your stack