What’s Vulnerable › Vulnerabilities
CVE-2026-91164: Warpgate: API tokens bypass the user's allowed_ip_ranges restriction
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-24
- Weakness: CWE-284
Description
Warpgate is an open source SSH, HTTPS and MySQL bastion host for Linux. From 0.23.0 until 0.27.3, HTTP API token authentication resolves ConfigProvider::validate_api_token into RequestAuthorization::UserToken without enforcing the owning user's allowed_ip_ranges against the trusted client address in warpgate-protocol-http/src/common.rs. An attacker holding a leaked, phished, or exfiltrated X-Warpgate-Token can therefore use it from a prohibited network location. Deployments without allowed_ip_ranges are unaffected, and HTTP target proxying plus SSH, MySQL, PostgreSQL, RDP, VNC, and Kubernetes paths do not accept this vulnerable HTTP token flow. This issue is fixed in version 0.27.3.
Affected products
- warp-tech warpgate: from 0.23.0, < 0.27.3
References
- https://github.com/warp-tech/warpgate/commit/8cb33a1a7c447ab0cde3a1ee9f95bf9dde905482
- https://github.com/warp-tech/warpgate/pull/2356
- https://github.com/warp-tech/warpgate/releases/tag/v0.27.3
- https://github.com/warp-tech/warpgate/security/advisories/GHSA-qmr2-wp96-h9ff
Get alerted when CVE-2026-91164 or the next vulnerability affects your stack