What’s Vulnerable › Vulnerabilities
CVE-2026-91206: Apache Roller: Reflected XSS in the optional LDAP comment authenticator
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-28 · updated 2026-09-30
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Apache Roller 6.1.5 allows a remote attacker to perform reflected cross-site scripting through the optional LDAP comment authenticator, which writes request parameter values into its HTML form without escaping. This affects only sites configured to use LdapCommentAuthenticator, and a victim whose session has already loaded the authenticator form must follow a crafted link. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which escapes the reflected values.
Affected products
References
- https://github.com/apache/roller/pull/191
- https://lists.apache.org/thread/tljwqdttq8tgg6hr8sxlcnwpxl6pch4s
- http://www.openwall.com/lists/oss-security/2026/09/25/24
Get alerted when CVE-2026-91206 or the next vulnerability affects your stack