What’s Vulnerable › Vulnerabilities
CVE-2026-9133: Arbitrary file read in rabbitmq-aws plugin
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-20 · updated 2026-07-23
- Weakness: CWE-489
Description
Active debug code exists in the ARN resolver of amazon-mq rabbitmq-aws before version 0.2.1. A debug ARN scheme (arn:aws-debug:file) accepted by the PUT /api/aws/arn/validate validation endpoint might allow remote authenticated users to perform arbitrary file reads on any file accessible to the RabbitMQ process. To remediate this issue, customers should upgrade to version 0.2.1 of rabbitmq-aws. If RabbitMQ is configured to use TLS for connections, we also recommend rotating any associated private certificate keys.
Affected products
- AWS RabbitMQ AWS: from 0.1.0 through 0.2.0
References
- https://aws.amazon.com/security/security-bulletins/2026-034-aws/
- https://github.com/amazon-mq/rabbitmq-aws/releases/tag/0.2.1
- https://github.com/amazon-mq/rabbitmq-aws/security/advisories/GHSA-8554-wg4r-7hxm
Get alerted when CVE-2026-9133 or the next vulnerability affects your stack