What’s Vulnerable › Vulnerabilities
CVE-2026-9151: Command Injection Vulnerability in OpenVPN on Multiple TP-Link Archer Routers
- Severity: high (CVSS 8.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability exists in the VPN module of TP-Link Archer AX12 v1, AX17 v1. AX18 v1, and AX1300 v1.6 routers. This vulnerability allows an adjacent, authenticated attacker to execute arbitrary commands on the device by importing a specially crafted VPN client configuration file. The issue stems from improper filtering of special characters. Successful exploitation of this vulnerability may enable an attacker to gain full control of the affected device, potentially compromising configuration integrity, network security, and service availability.
Affected products
- TP-Link Systems Inc. Archer AX12 V1: before V1_1.5.0 Build 20260605 — fixed in V1_1.5.0 Build 20260605
- TP-Link Systems Inc. Archer AX1300 v1.6: before V1_1.5.0 Build 20260605 — fixed in V1_1.5.0 Build 20260605
- TP-Link Systems Inc. Archer AX18 v1: before V1_1.5.0 Build 20260605 — fixed in V1_1.5.0 Build 20260605
- TP Link Systems Inc. Archer AX17 v1: before V1_1.5.0 Build 20260605 — fixed in V1_1.5.0 Build 20260605
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer AX12 V1 V1_1.5.0 Build 20260605; TP-Link Systems Inc. Archer AX1300 v1.6 V1_1.5.0 Build 20260605; TP-Link Systems Inc. Archer AX18 v1 V1_1.5.0 Build 20260605; TP Link Systems Inc. Archer AX17 v1 V1_1.5.0 Build 20260605. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/archer-ax12/#Firmware
- https://www.tp-link.com/en/support/download/archer-ax17/#Firmware
- https://www.tp-link.com/en/support/download/archer-ax18/#Firmware
- https://www.tp-link.com/us/support/download/archer-ax1300/#Firmware
- https://www.tp-link.com/us/support/faq/5125/
Get alerted when CVE-2026-9151 or the next vulnerability affects your stack