What’s Vulnerable › Vulnerabilities
CVE-2026-91778
- Severity: high (CVSS 7.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-16
- Weakness: CWE-863
Description
In affected versions of Octopus Server, users with certain scoped permission sets could execute arbitrary scripts on a worker (including the Octopus Server built-in worker). Incorrect permission validation during script execution would allow the script to execute without the user possessing the required authorisation.
Affected products
- Octopus Deploy Octopus Server: from 2019.0.0 before 2026.1.11725; from 2026.2.0 before 2026.2.13344; from 2026.3.0 before 2026.3.11816 — fixed in 2026.1.11725, 2026.2.13344, 2026.3.11816
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2026.1.11725, 2026.2.13344, 2026.3.11816. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-91778 or the next vulnerability affects your stack