What’s Vulnerable › Vulnerabilities
CVE-2026-9186: Langflow is vulnerable to stored cross-site scripting and IP spoofing due to unsanitized Markdown rendering and untrusted proxy header trust
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-284
Description
IBM Langflow OSS 1.0.0 through 1.11.2 allows remote authenticated attackers to bypass localhost-only MCP configuration installation by spoofing X-Forwarded-For: 127.0.0.1 header, enabling arbitrary writes to IDE config files (~/.cursor/mcp.json, etc.).
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.3 — fixed in 1.11.3
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9186 or the next vulnerability affects your stack