What’s Vulnerable › Vulnerabilities
CVE-2026-91863: Apache Neethi: Uncontrolled recursion while parsing crafted WS-Policy documents allows denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-24
- Weakness: CWE-674
Description
A specially crafted WS-Policy document with deeply nested policy elements can bypass Neethi's nesting-depth limit and exhaust the thread stack, crashing the parser (denial of service). Users are recommended to upgrade to version 3.2.4, which fixes this issue.
Affected products
- Apache Software Foundation Apache Neethi: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Neethi 3.2.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/72kxj71lvrqqx90xxqqctvpbw0t8mpxw
- http://www.openwall.com/lists/oss-security/2026/09/18/10
Get alerted when CVE-2026-91863 or the next vulnerability affects your stack