What’s Vulnerable › Vulnerabilities
CVE-2026-91864: Apache Neethi: Crafted WS-Policy documents bypass element/attribute limits causing memory exhaustion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-25
- Weakness: CWE-770
Description
A specially crafted WS-Policy document can pack unlimited content inside a policy assertion, which Neethi copies into memory without counting it against its size limits, exhausting the heap (denial of service). Users are recommended to upgrade to version 3.2.4, which fixes this issue.
Affected products
- Apache Software Foundation Apache Neethi: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Neethi 3.2.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/400kbynbyhqhsjkv1yz251jm9wdz8z69
- http://www.openwall.com/lists/oss-security/2026/09/18/11
Get alerted when CVE-2026-91864 or the next vulnerability affects your stack