What’s Vulnerable › Vulnerabilities
CVE-2026-91865: Apache Neethi: Crafted policy references cause exponential expansion during normalization leading to denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-25
- Weakness: CWE-770
Description
A small WS-Policy document using repeated policy references can force Neethi to re-expand the same references exponentially during normalization, consuming huge amounts of CPU and memory (denial of service). Users are recommended to upgrade to version 3.2.4, which fixes this issue.
Affected products
- Apache Software Foundation Apache Neethi: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Neethi 3.2.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/l48btqh02rlpsgf5p6r5ltqk1cb69dtc
- http://www.openwall.com/lists/oss-security/2026/09/18/12
Get alerted when CVE-2026-91865 or the next vulnerability affects your stack