What’s Vulnerable › Vulnerabilities
CVE-2026-91881
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-295
Description
Dell Terraform Provider for Redfish, versions prior to 1.6.2, contains an Improper Certificate Validation vulnerability in the HTTP transport component. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to information exposure and unauthorized access. This is a Critical severity vulnerability as it allows an unauthenticated attacker to intercept all Redfish BMC traffic including credentials by performing a man-in-the-middle attack, since TLS certificate verification is unconditionally disabled in the base HTTP transport. Dell recommends customers to upgrade at the earliest opportunity.
Affected products
- Dell Terraform Provider for Redfish: before 1.6.2 or later — fixed in 1.6.2 or later
How to fix
Upgrade to a fixed version: Dell Terraform Provider for Redfish 1.6.2 or later. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-91881 or the next vulnerability affects your stack