What’s Vulnerable › Vulnerabilities
CVE-2026-91928: Apache Sling XSS: Sanitizer bypass, uncontrolled resource consumption and failure pf protection mechanisms
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-30
- Weakness: CWE-79
Description
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.
Affected products
- Apache Software Foundation Apache Sling XSS: before 2.4.12 — fixed in 2.4.12
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sling XSS 2.4.12. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yfb1q6zob8mth5lr4jnsy3lhx9rfwb02
- http://www.openwall.com/lists/oss-security/2026/09/23/13
Get alerted when CVE-2026-91928 or the next vulnerability affects your stack