What’s Vulnerable › Vulnerabilities
CVE-2026-91932: Flowise before 3.1.4 Remote Code Execution via cwd Parameter
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-16
- Weakness: CWE-20
Description
Flowise before 3.1.4 contains a validation bypass vulnerability in MCP server configuration allowing authenticated attackers remote code execution through an unvalidated cwd parameter. Attackers can bypass path validation using clean filenames in the args array while controlling the working directory to execute malicious code.
Affected products
- FlowiseAI Flowise: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-x7x8-95gh-42xm
- https://www.vulncheck.com/advisories/flowise-before-3.1.4-remote-code-execution-via-cwd-parameter
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-x7x8-95gh-42xm
Get alerted when CVE-2026-91932 or the next vulnerability affects your stack