What’s Vulnerable › Vulnerabilities
CVE-2026-91936: Flowise before 3.1.4 Script Injection via Docker Workflows
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-17
- Weakness: CWE-78
Description
Flowise versions before 3.1.4 contain a script injection vulnerability in Docker image build workflows where workflow_dispatch inputs are directly interpolated into shell run blocks. Attackers with repository write access can inject shell metacharacters through inputs like tag_version and node_version to execute arbitrary commands and steal AWS credentials and Docker Hub tokens.
Affected products
- FlowiseAI Flowise: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-jrcq-qjw5-xx5q
- https://www.vulncheck.com/advisories/flowise-before-3.1.4-script-injection-via-docker-workflows
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-jrcq-qjw5-xx5q
Get alerted when CVE-2026-91936 or the next vulnerability affects your stack