What’s Vulnerable › Vulnerabilities
CVE-2026-91940: crawl4ai before 0.9.3 Arbitrary File Write via PDFContentScrapingStrategy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-16
- Weakness: CWE-22
Description
crawl4ai before 0.9.3 contains an arbitrary file write vulnerability in PDFContentScrapingStrategy where the _filter_untrusted_fields function fails to validate untrusted configuration fields. Attackers can submit crafted config bodies with malicious image_save_dir paths to write attacker-controlled bytes into any directory accessible to the service account.
Affected products
- unclecode crawl4ai: from 0.9.0 before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-xpp7-j28w-2gvx
- https://www.vulncheck.com/advisories/crawl4ai-before-0.9.3-arbitrary-file-write-via-pdfcontentscrapingstrategy
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-xpp7-j28w-2gvx
Get alerted when CVE-2026-91940 or the next vulnerability affects your stack