What’s Vulnerable › Vulnerabilities
CVE-2026-91941: Crawl4AI before 0.9.3 Denial of Service via PDFContentScrapingStrategy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-20
- Weakness: CWE-400
Description
Crawl4AI before 0.9.3 contains an uncontrolled resource consumption vulnerability in PDFContentScrapingStrategy that allows untrusted clients to cause denial of service. Attackers can select the PDF scraping strategy in POST requests to download large remote PDFs without size or page limits, exhausting disk, CPU, and bandwidth on shared workers.
Affected products
- unclecode crawl4ai: before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-v2rm-hvrj-2x9q
- https://www.vulncheck.com/advisories/crawl4ai-before-0.9.3-denial-of-service-via-pdfcontentscrapingstrategy
Get alerted when CVE-2026-91941 or the next vulnerability affects your stack