What’s Vulnerable › Vulnerabilities
CVE-2026-91942: crawl4ai before 0.9.3 Cross-Site Scripting via innerHTML
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-17
- Weakness: CWE-79
Description
crawl4ai before 0.9.3 contains a DOM-based cross-site scripting vulnerability in the Docker Playground UI that assigns untrusted crawl results to element.innerHTML. Attackers can craft malicious PDFs with event-handler markup to execute JavaScript in the Playground origin and steal API tokens from sessionStorage for authenticated API abuse.
Affected products
- unclecode crawl4ai: before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-7g3g-vhm6-79f3
- https://www.vulncheck.com/advisories/crawl4ai-before-0.9.3-cross-site-scripting-via-innerhtml
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-7g3g-vhm6-79f3
Get alerted when CVE-2026-91942 or the next vulnerability affects your stack