What’s Vulnerable › Vulnerabilities
CVE-2026-91943: Crawl4AI before 0.9.3 SSRF via PDFContentScrapingStrategy
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-16
- Weakness: CWE-918
Description
Crawl4AI before 0.9.3 contains a server-side request forgery vulnerability in PDFContentScrapingStrategy where _get_pdf_path() re-downloads targets with Python requests without egress validation. Authenticated attackers can supply URLs that redirect to internal addresses or use DNS rebinding to access internal services, exfiltrating responses through PDF text extraction in crawl results.
Affected products
- unclecode crawl4ai: before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-q5rj-45vw-vp2g
- https://www.vulncheck.com/advisories/crawl4ai-before-0.9.3-ssrf-via-pdfcontentscrapingstrategy
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-q5rj-45vw-vp2g
Get alerted when CVE-2026-91943 or the next vulnerability affects your stack