What’s Vulnerable › Vulnerabilities
CVE-2026-91952: FreeRDP before 3.31.0 Denial of Service via pool_decode_rect
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-835
Description
FreeRDP versions before 3.31.0 contain an infinite-loop denial of service in the pool_decode_rect function when decoding AVC444 metablocks with more region rectangles than preallocated worker array size. A malicious RDP server can send crafted AVC444 graphics updates causing the threaded decode path to loop indefinitely, consuming CPU and preventing normal client operation.
Affected products
- FreeRDP: from 3.11.0 (excl.) before 3.31.0 — fixed in 3.31.0
How to fix
Upgrade to a fixed version: FreeRDP 3.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-m85m-3qxv-63h5
- https://www.vulncheck.com/advisories/freerdp-before-3.31.0-denial-of-service-via-pool-decode-rect
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-m85m-3qxv-63h5
Get alerted when CVE-2026-91952 or the next vulnerability affects your stack