What’s Vulnerable › Vulnerabilities
CVE-2026-91955: FreeRDP before 3.31.0 Denial of Service via Desktop Dimensions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-369
Description
FreeRDP before 3.31.0 fails to validate client-supplied DesktopWidth and DesktopHeight values during GCC negotiation, allowing remote attackers to crash the server. Attackers can send crafted RDP packets with zero or oversized dimensions to trigger division-by-zero or assertion failures in multifragment update capability calculations, terminating the server process.
Affected products
- FreeRDP: before 3.31.0 — fixed in 3.31.0
How to fix
Upgrade to a fixed version: FreeRDP 3.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-4464-r7qj-pgrx
- https://www.vulncheck.com/advisories/freerdp-before-3.31.0-denial-of-service-via-desktop-dimensions
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-4464-r7qj-pgrx
Get alerted when CVE-2026-91955 or the next vulnerability affects your stack