What’s Vulnerable › Vulnerabilities
CVE-2026-91957: FreeRDP before 3.31.0 Use-After-Free via smartcard worker
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-416
Description
FreeRDP before 3.31.0 contains a use-after-free vulnerability in the smartcard RDPDR device handler when worker thread creation fails after device registration. Attackers can trigger thread creation failure during channel setup to cause device pointer deallocation while devman retains a reference, leading to crash or code execution.
Affected products
- FreeRDP: before 3.31.0 — fixed in 3.31.0
How to fix
Upgrade to a fixed version: FreeRDP 3.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-j5mq-3349-gwmm
- https://www.vulncheck.com/advisories/freerdp-before-3.31.0-use-after-free-via-smartcard-worker
Get alerted when CVE-2026-91957 or the next vulnerability affects your stack