What’s Vulnerable › Vulnerabilities
CVE-2026-91959: FreeRDP before 3.31.0 Buffer Over-read via RTS Gateway
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-125
Description
FreeRDP before 3.31.0 contains a buffer over-read vulnerability in the rts_read_result function within the RPC gateway transport parser. Attackers can send a malicious BIND_ACK PDU with a truncated result entry to trigger an out-of-bounds read causing process abort.
Affected products
- FreeRDP: before 3.31.0 — fixed in 3.31.0
How to fix
Upgrade to a fixed version: FreeRDP 3.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-pj8w-fh79-f438
- https://www.vulncheck.com/advisories/freerdp-before-3.31.0-buffer-over-read-via-rts-gateway
Get alerted when CVE-2026-91959 or the next vulnerability affects your stack