What’s Vulnerable › Vulnerabilities
CVE-2026-91979: Vikunja before 2.6.0 Denial of Service via Decompression Bomb
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-17
- Weakness: CWE-400
Description
Vikunja before 2.6.0 fails to limit archive expansion during data import, allowing authenticated users to cause denial of service. Attackers can upload highly compressed files that expand to tens of gigabytes in memory and disk, exhausting server resources and crashing the instance.
Affected products
- go-vikunja vikunja: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: go-vikunja vikunja 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/go-vikunja/vikunja/security/advisories/GHSA-w7jp-mf2v-8342
- https://www.vulncheck.com/advisories/vikunja-before-2.6.0-denial-of-service-via-decompression-bomb
Get alerted when CVE-2026-91979 or the next vulnerability affects your stack