What’s Vulnerable › Vulnerabilities
CVE-2026-9198: IBM Langflow Code Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-08-04
- EPSS: 28.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-94
Description
IBM Langflow OSS 1.0.0 through 1.10.0 allows unauthenticated attackers to chain /api/v1/auto_login (mints SUPERUSER tokens to any network caller) with /api/v1/validate/code (executes user code via exec()) to achieve full RCE on default Langflow deployments
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.1 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.1. Check the vendor advisory for mitigations.
References
- https://www.ibm.com/support/pages/node/7278927
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-9198
Get alerted when CVE-2026-9198 or the next vulnerability affects your stack