What’s Vulnerable › Vulnerabilities
CVE-2026-91981: Vikunja before 2.6.0 User Enumeration via v2 API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-21
- Weakness: CWE-200
Description
Vikunja versions before 2.6.0 fail to properly validate link-share tokens in the v2 API user search endpoints. Attackers with a read-only share link can enumerate project users via the projects endpoint and confirm arbitrary usernames exist via the global search endpoint.
Affected products
- go-vikunja vikunja: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: go-vikunja vikunja 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/go-vikunja/vikunja/security/advisories/GHSA-vfxw-3x8p-2vjr
- https://www.vulncheck.com/advisories/vikunja-before-2.6.0-user-enumeration-via-v2-api
- https://github.com/go-vikunja/vikunja/security/advisories/GHSA-vfxw-3x8p-2vjr
Get alerted when CVE-2026-91981 or the next vulnerability affects your stack