What’s Vulnerable › Vulnerabilities
CVE-2026-91983: Vikunja before 2.6.0 API Token Scope Bypass via expand Parameter
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-16
- Weakness: CWE-863
Description
Vikunja before 2.6.0 contains an API token scope bypass vulnerability in task read endpoints where authorization fails to inspect query string parameters. Attackers with limited token scopes can use the expand parameter to access restricted data like comments, reactions, and time entries without proper permission verification.
Affected products
- go-vikunja vikunja: from 1.0.0 before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: go-vikunja vikunja 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/go-vikunja/vikunja/security/advisories/GHSA-9rg3-v78m-26q8
- https://www.vulncheck.com/advisories/vikunja-before-2.6.0-api-token-scope-bypass-via-expand-parameter
- https://github.com/go-vikunja/vikunja/security/advisories/GHSA-9rg3-v78m-26q8
Get alerted when CVE-2026-91983 or the next vulnerability affects your stack