What’s Vulnerable › Vulnerabilities
CVE-2026-91988: atomic-agents-stack before 1.1.0 Remote Code Execution via HTTP MCP
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-319
Description
atomic-agents-stack before 1.1.0 accepts cleartext HTTP schemes in the HTTP MCP server-registry backend factory, allowing network man-in-the-middle attackers to rewrite catalog responses. Attackers can inject arbitrary command and argument values that are spawned as local subprocesses by MCPClientPool to achieve code execution on the agent host.
Affected products
- dep0we atomic-agents-stack: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: dep0we atomic-agents-stack 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/dep0we/atomic-agents-stack/security/advisories/GHSA-xhcr-cqfr-m3hv
- https://www.vulncheck.com/advisories/atomic-agents-stack-before-1.1.0-remote-code-execution-via-http-mcp
Get alerted when CVE-2026-91988 or the next vulnerability affects your stack