What’s Vulnerable › Vulnerabilities
CVE-2026-91989: atomic-agents-stack before 1.1.0 Path Traversal via dashboard serve.py
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-22
Description
atomic-agents-stack before 1.1.0 contains a path traversal vulnerability in the dashboard HTTP server that allows remote attackers to read arbitrary files by supplying directory traversal sequences in request paths. Attackers can bypass path containment checks by including '../' segments in requests to the DashboardHandler.do_GET endpoint to access files outside the intended agents_root directory.
Affected products
- dep0we atomic-agents-stack: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: dep0we atomic-agents-stack 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/dep0we/atomic-agents-stack/security/advisories/GHSA-rm43-82j9-r4mj
- https://www.vulncheck.com/advisories/atomic-agents-stack-before-1.1.0-path-traversal-via-dashboard-serve-py
Get alerted when CVE-2026-91989 or the next vulnerability affects your stack