What’s Vulnerable › Vulnerabilities
CVE-2026-91990: Tornado before 6.5.8 Memory Amplification DoS via multipart
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-16
- Weakness: CWE-770
Description
Tornado before 6.5.8 contains a memory amplification vulnerability in parse_multipart_form_data that splits multipart data before validating the max_parts limit. Attackers can send crafted multipart requests with many parts to create large transient lists, exhausting server memory and causing denial of service.
Affected products
- Pypi Tornado: before 6.5.8; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+77) — fixed in 6.5.8
- tornadoweb tornado: before 6.5.8 — fixed in 6.5.8
How to fix
Upgrade to a fixed version: Pypi Tornado 6.5.8; tornadoweb tornado 6.5.8. Check the vendor advisory for mitigations.
References
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-8423-8fgw-73vq
- https://www.vulncheck.com/advisories/tornado-before-6.5.8-memory-amplification-dos-via-multipart
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-8423-8fgw-73vq
Get alerted when CVE-2026-91990 or the next vulnerability affects your stack