What’s Vulnerable › Vulnerabilities
CVE-2026-91992: Tornado before 6.5.7 Credential Leak via Handle Reuse
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-17
- Weakness: CWE-200
Description
Tornado before 6.5.7 contains a credential leak vulnerability in CurlAsyncHTTPClient where pycurl handles are reused across requests without proper state clearing. Attackers can obtain sensitive credentials by issuing requests through the same client instance, allowing TLS certificates or proxy authentication to persist across unintended requests.
Affected products
- Pypi Tornado: before 6.5.7; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+76) — fixed in 6.5.7
- tornadoweb tornado: before 6.5.7 — fixed in 6.5.7
How to fix
Upgrade to a fixed version: Pypi Tornado 6.5.7; tornadoweb tornado 6.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-pw6j-qg29-8w7f
- https://www.vulncheck.com/advisories/tornado-before-6.5.7-credential-leak-via-handle-reuse
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-pw6j-qg29-8w7f
Get alerted when CVE-2026-91992 or the next vulnerability affects your stack