What’s Vulnerable › Vulnerabilities
CVE-2026-91995: pig before 4.1.0 Unverified Password Change via /register/password
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-620
Description
pig before 4.1.0 contains an authentication bypass vulnerability in the /register/password endpoint where password verification results are discarded, allowing any value as the current password. Remote attackers can submit a username with an incorrect current password to overwrite any account credential including the admin account and gain full administrative control.
Affected products
- pig-mesh pig: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: pig-mesh pig 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/geo-chen/oss/blob/main/pig.md
- https://github.com/pig-mesh/pig
- https://github.com/pig-mesh/pig/blob/v4.0.0/pig-upms/pig-upms-biz/src/main/java/com/pig4cloud/pig/admin/controller/SysRegisterController.java#L21-L53
- https://github.com/pig-mesh/pig/blob/v4.0.0/pig-upms/pig-upms-biz/src/main/java/com/pig4cloud/pig/admin/service/impl/SysUserServiceImpl.java#L650-L669
- https://github.com/pig-mesh/pig/commit/ce958668f399110b97b3f1fcc5f517ff9bcfd535
- https://github.com/pig-mesh/pig/issues/1249
- https://www.vulncheck.com/advisories/pig-before-4.1.0-unverified-password-change-via-register-password
Get alerted when CVE-2026-91995 or the next vulnerability affects your stack